La app de mensajería instantánea WhatsApp, publicó que a partir de 2017, tampoco funcionará en dispositivos con sistemas operativos Android 2.1 Eclair y Android 2.2 Froyo, que aún tienen algunos modelos como el HTC Desire.

Debido a que dichos sistemas operativos no se pueden actualizar, los usuarios tendrán que cambiar de dispositivo si desean seguir usando WhatsApp.

Por lo tanto, a finales de este año los dispositivos BlackBerry, Nokia S40, Symbian S60, Windows Phone 7.1, Android 2.1 y 2.2, no contarán con el servicio de mensajería.